Xero Error message A validation exception occurred Account code or ID must be specified
Question/Problem
The feedback "A validation exception occurred Account code or ID must be specified" is being received when synchronising one or more invoices with Xero.
Cause
There may be nominal account mappings missing within your Xero integration configuration.
Resolution/Solution
You must ensure the following nominal accounts exist within Xero and that mappings exist within Khaos Control:
- Sales
- Inventory
- Cost of Goods Sold
- Stock Adjustment
- Sales Delivery
- General Expenses
See Also
More information can be found within our Xero Integration Guide: /article/khaos-control-cloud-xero-guide